Some checks failed
Release Alpine apk for ARM64v8 / compilation-arm64v8 (push) Failing after 57s
30 lines
924 B
Text
Executable file
30 lines
924 B
Text
Executable file
# Contributor: ITmodulo <itmodulo@disroot.org>
|
|
# Maintainer: ITmodulo <itmodulo@disroot.org>
|
|
pkgname=CameraCtl
|
|
pkgver=0.0.1
|
|
pkgrel=0
|
|
pkgdesc="Pocophone F1 tweaked camera"
|
|
url="https://gitlab.com/NekoCWD/cameractrl"
|
|
license="GPL-3.0-or-later"
|
|
arch="all"
|
|
makedepends="desktop-file-utils blueprint-compiler vala build-base linux-headers git libgudev-dev gtk4.0-dev gtk4-layer-shell-dev libadwaita-dev meson"
|
|
source="$pkgname-$pkgver.tar.gz::https://gitlab.com/NekoCWD/cameractrl/-/archive/master/cameractrl-master.tar.gz"
|
|
options="!check" # not needed
|
|
|
|
build() {
|
|
cd "cameractrl-master"
|
|
abuild-meson . output
|
|
meson compile -C output
|
|
}
|
|
|
|
# check() {
|
|
#
|
|
# }
|
|
|
|
package() {
|
|
cd src/cameractrl-master
|
|
DESTDIR="$pkgdir" meson install --no-rebuild -C output
|
|
}
|
|
sha512sums="
|
|
f0ddf35086c52103cadf183ef9b35b1e785f6031db47b369bb6a52edc5d87eae91f7e56a4cbf63fa49b1ee923aceb26a3de5ab01ca824afaba4e6d8e93a135e7 CameraCtl-0.0.1.tar.gz
|
|
"
|