add melon patched
All checks were successful
Release Alpine apk for ARM64v8 / compilation-arm64v8 (push) Successful in 9m58s

This commit is contained in:
ITmodulo 2025-02-11 23:22:38 +01:00
parent 4595330ce7
commit d988b6403f
3 changed files with 702 additions and 3 deletions

View file

@ -45,9 +45,7 @@ jobs:
# mv aports/community/hexagonrpcd srcpkgs/
# mv aports/testing/gmic srcpkgs/
# mv aports/testing/dissent srcpkgs/
git clone --depth 1 https://codeberg.org/comcloudway/apkbuild-collection.git
mv apkbuild-collection/testing/melon srcpkgs/
ls -lah srcpkgs
ls srcpkgs | tr ' ' '\n'
mv srcpkgs /home/runner && chown -R runner:runner /home/runner/srcpkgs
echo "/home/runner/packages/srcpkgs" >> /etc/apk/repositories
su - runner -c 'export PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"; cd srcpkgs; for i in $(ls ./ ); do cd $i && abuild -r -c; cd .. ; done'

View file

@ -0,0 +1,646 @@
From 3a6244e5927fbcc8afd8953d81fa99deec6de76a Mon Sep 17 00:00:00 2001
From: Jakob Meier <comcloudway@ccw.icu>
Date: Sun, 17 Mar 2024 07:54:21 +0100
Subject: [PATCH] update metainfo file to pass appstream validate
---
data/icu.ccw.Melon.desktop.in | 2 +-
data/icu.ccw.Melon.metainfo.xml.in.in | 356 +++++++++++++-------------
po/de.po | 36 ++-
po/fa.po | 31 ++-
po/melon.pot | 31 ++-
5 files changed, 243 insertions(+), 213 deletions(-)
diff --git a/data/icu.ccw.Melon.desktop.in b/data/icu.ccw.Melon.desktop.in
index e02d30f..16a164b 100644
--- a/data/icu.ccw.Melon.desktop.in
+++ b/data/icu.ccw.Melon.desktop.in
@@ -7,7 +7,7 @@ Icon=@appid@
Terminal=false
Type=Application
StartupNotify=true
-Categories=Graphics;Network;Viewer;GTK;GNOME;
+Categories=Graphics;Network;Video;Player;GTK;GNOME;
# Translators: Search terms to find this application. Do NOT translate or localize the semicolons! The list MUST also end with a semicolon!
Keywords=viewer;videos;stream;browse;
X-GNOME-UsesNotifications=true
diff --git a/data/icu.ccw.Melon.metainfo.xml.in.in b/data/icu.ccw.Melon.metainfo.xml.in.in
index d05cdf4..5e7c949 100644
--- a/data/icu.ccw.Melon.metainfo.xml.in.in
+++ b/data/icu.ccw.Melon.metainfo.xml.in.in
@@ -1,189 +1,195 @@
<?xml version="1.0" encoding="UTF-8"?>
<component type="desktop-application">
- <id>@app_id@</id>
+ <id>@app_id@</id>
- <name translate="no">@prettyname@</name>
- <icon type="stock">@app_id@</icon>
- <summary>Video player that aims to be mobile friendly. Stream videos on the go from multiple sources.</summary>
+ <name translate="no">@prettyname@</name>
+ <icon type="stock">@app_id@</icon>
+ <summary>Stream videos on the go from different services</summary>
- <!-- developer_name tag deprecated with Appstream 1.0 -->
- <developer_name translate="no">@authorfullname@</developer_name>
- <developer id="codeberg.org">
- <name translate="no">@authorfullname@</name>
- </developer>
- <update_contact translate="no">@authoremail@</update_contact>
+ <developer id="codeberg.org">
+ <name translate="no">@authorfullname@</name>
+ </developer>
+ <update_contact translate="no">@authoremail@</update_contact>
- <metadata_license>CC0-1.0</metadata_license>
- <project_license>@license@</project_license>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>@license@</project_license>
- <recommends>
- <display_length compare="ge">360</display_length>
- <internet>always</internet>
- </recommends>
- <supports>
- <control>pointing</control>
- <control>keyboard</control>
- <control>touch</control>
- </supports>
+ <recommends>
+ <display_length compare="ge">360</display_length>
+ <internet>always</internet>
+ </recommends>
+ <supports>
+ <control>pointing</control>
+ <control>keyboard</control>
+ <control>touch</control>
+ </supports>
- <description>
- <p>
- Melon allows you to watch videos, subscribe to channels and bookmark playlists from multiple services.
- </p>
- <p>
- The following services are currently supported:
- </p>
- <ul>
- <li>Invidious (to access YouTube)</li>
- <li>PeerTube (experimental)</li>
- <li>Nebula (account required to watch videos)</li>
- </ul>
- </description>
+ <description>
+ <p>
+ Melon allows you to watch videos, subscribe to channels and bookmark playlists from multiple services.
+ </p>
+ <p>
+ Access to these services is provided via so called servers (aka plugins), which communicate with the API of said service.
+ The following services are currently supported:
+ </p>
+ <ul>
+ <li>Invidious (to access YouTube)</li>
+ <li>PeerTube (experimental)</li>
+ <li>Nebula (account required to watch videos)</li>
+ </ul>
+ </description>
- <url type="bugtracker">@gitrepo@/issues</url>
- <url type="homepage">@website@</url>
- <url type="translate">https://translate.codeberg.org/engage/melon/</url>
- <url type="vcs-browser">@gitrepo@</url>
+ <url type="bugtracker">@gitrepo@/issues</url>
+ <url type="homepage">@website@</url>
+ <url type="translate">https://translate.codeberg.org/engage/melon/</url>
+ <url type="vcs-browser">@gitrepo@</url>
- <launchable type="desktop-id">@app_id@.desktop</launchable>
- <screenshots>
- <screenshot type="default">
- <caption>
- Default Melon home screen showing: crickets chirping; Subscribe to a channel first, to view uploads
- </caption>
- <image>https://codeberg.org/comcloudway/melon/media/branch/main/screenshots/empty_feed.png</image>
- </screenshot>
- <screenshot>
- <caption>
- List of available servers: Invidious, Nebula, Peertube; including server description
- </caption>
- <image>https://codeberg.org/comcloudway/melon/media/branch/main/screenshots/server_list.png</image>
- </screenshot>
- <screenshot>
- <caption>
- Video Screen, with a video player at the top, the video title below, an expandable description, channel information and a bookmark button
- </caption>
- <image>https://codeberg.org/comcloudway/melon/media/branch/main/screenshots/video.png</image>
- </screenshot>
- </screenshots>
- <releases>
- <release version="0.2.0" date="2024-03-16">
- <description translate="no">
- <ul>
- <li>
- Melon now remebers your playback position:
- Pick up where you left of
- </li>
- <li>
- Introducing Playlist-Mode:
- Click the play button when viewing a playlist to start playing.
- A slightly modified player will allow you to skip tracks,
- enable shuffle mode or repeat videos.
- </li>
- <li>
- Goodbye WebView. Hello GStreamer:
- Melon now has it's own simple video player,
- with slide gestures to change the volume and brightness
- and double click gesture to skip ahead/back.
- </li>
- </ul>
- </description>
- </release>
- <release version="0.1.3" date="2024-03-09">
- <description translate="no">
- <ul>
- <li>
- made melon translateable. Help translate melon to your language
- </li>
- <li>
- decode title and description using Unidecode
- </li>
- <li>
- add load more pagination to history page
- </li>
- <li>
- show spinner on new pages while waiting for results
- </li>
- </ul>
- </description>
- </release>
- <release version="0.1.2" date="2024-02-29">
- <description translate="no">
- <ul>
- <li>
- experimental peertube support
- </li>
- <li>
- new-uploads-feed speedup by fetching videos on 10 threads
- </li>
- <li>
- faster feed rendering by loading thumbnails on separate thread
- </li>
- </ul>
- </description>
- </release>
- <release version="0.1.1" date="2024-02-29">
- <description translate="no">
- <p>fix what's-new feed duplicate error</p>
- </description>
- </release>
- <release version="0.1.0" date="2024-02-21">
- <description translate="no">
- <p>
- First stable Version
- </p>
- <p>
- Features:
- </p>
- <ul>
- <li>
- Import Subscriptions, Playlists and History from Newpipe (.db file
- inside the .zip)
- </li>
- <li>
- Browse Server feeds and search for channels, playlists and videos
- </li>
- <li>
- Browse uploads and playlists from channels
- </li>
- <li>
- Bookmark playlists and create new ones
- </li>
- <li>
- Add videos to local playlist
- </li>
- <li>
- Follow channels and view new uploads in a home feed
- </li>
- <li>
- Support for invidious and nebula source
- </li>
- </ul>
- </description>
- </release>
- </releases>
+ <launchable type="desktop-id">@app_id@.desktop</launchable>
+ <categories>
+ <category>Graphics</category>
+ <category>Network</category>
+ <category>Video</category>
+ <category>Player</category>
+ </categories>
- <translation type="gettext">@app_id@</translation>
+ <screenshots>
+ <screenshot type="default">
+ <caption>
+ Default Melon home screen showing: crickets chirping; Subscribe to a channel first, to view uploads
+ </caption>
+ <image>https://codeberg.org/comcloudway/melon/media/branch/main/screenshots/empty_feed.png</image>
+ </screenshot>
+ <screenshot>
+ <caption>
+ List of available servers: Invidious, Nebula, Peertube; including server description
+ </caption>
+ <image>https://codeberg.org/comcloudway/melon/media/branch/main/screenshots/server_list.png</image>
+ </screenshot>
+ <screenshot>
+ <caption>
+ Video Screen, with a video player at the top, video meta data and a bookmark button
+ </caption>
+ <image>https://codeberg.org/comcloudway/melon/media/branch/main/screenshots/video.png</image>
+ </screenshot>
+ </screenshots>
+ <releases>
+ <release version="0.2.0" date="2024-03-16">
+ <description translate="no">
+ <ul>
+ <li>
+ Melon now remebers your playback position:
+ Pick up where you left of
+ </li>
+ <li>
+ Introducing Playlist-Mode:
+ Click the play button when viewing a playlist to start playing.
+ A slightly modified player will allow you to skip tracks,
+ enable shuffle mode or repeat videos.
+ </li>
+ <li>
+ Goodbye WebView. Hello GStreamer:
+ Melon now has it's own simple video player,
+ with slide gestures to change the volume and brightness
+ and double click gesture to skip ahead/back.
+ </li>
+ </ul>
+ </description>
+ </release>
+ <release version="0.1.3" date="2024-03-09">
+ <description translate="no">
+ <ul>
+ <li>
+ Made melon translateable. Help translate melon to your language
+ </li>
+ <li>
+ Decode title and description using Unidecode
+ </li>
+ <li>
+ Add load more pagination to history page
+ </li>
+ <li>
+ Show spinner on new pages while waiting for results
+ </li>
+ </ul>
+ </description>
+ </release>
+ <release version="0.1.2" date="2024-02-29">
+ <description translate="no">
+ <ul>
+ <li>
+ Experimental peertube support
+ </li>
+ <li>
+ New-uploads-feed speedup by fetching videos on 10 threads
+ </li>
+ <li>
+ Faster feed rendering by loading thumbnails on separate thread
+ </li>
+ </ul>
+ </description>
+ </release>
+ <release version="0.1.1" date="2024-02-29">
+ <description translate="no">
+ <p>Fix what's-new feed duplicate error</p>
+ </description>
+ </release>
+ <release version="0.1.0" date="2024-02-21">
+ <description translate="no">
+ <p>
+ First stable Version
+ </p>
+ <p>
+ Features:
+ </p>
+ <ul>
+ <li>
+ Import Subscriptions, Playlists and History from Newpipe (.db file
+ inside the .zip)
+ </li>
+ <li>
+ Browse Server feeds and search for channels, playlists and videos
+ </li>
+ <li>
+ Browse uploads and playlists from channels
+ </li>
+ <li>
+ Bookmark playlists and create new ones
+ </li>
+ <li>
+ Add videos to local playlist
+ </li>
+ <li>
+ Follow channels and view new uploads in a home feed
+ </li>
+ <li>
+ Support for invidious and nebula source
+ </li>
+ </ul>
+ </description>
+ </release>
+ </releases>
- <content_rating type="oars-1.1">
- <content_attribute id="violence-cartoon">intense</content_attribute>
- <content_attribute id="violence-fantasy">intense</content_attribute>
- <content_attribute id="violence-realistic">intense</content_attribute>
- <content_attribute id="violence-bloodshed">intense</content_attribute>
- <content_attribute id="violence-sexual">intense</content_attribute>
- <content_attribute id="violence-desecration">intense</content_attribute>
- <content_attribute id="violence-slavery">intense</content_attribute>
- <content_attribute id="drugs-alcohol">moderate</content_attribute>
- <content_attribute id="drugs-narcotics">moderate</content_attribute>
- <content_attribute id="drugs-tobacco">moderate</content_attribute>
- <content_attribute id="sex-nudity">intense</content_attribute>
- <content_attribute id="sex-themes">intense</content_attribute>
- <content_attribute id="language-profanity">intense</content_attribute>
- <content_attribute id="language-humor">intense</content_attribute>
- <content_attribute id="language-discrimination">intense</content_attribute>
- <content_attribute id="money-purchasing">mild</content_attribute>
- <content_attribute id="money-advertising">intense</content_attribute>
- </content_rating>
+ <translation type="gettext">@app_id@</translation>
+
+ <content_rating type="oars-1.1">
+ <content_attribute id="violence-cartoon">intense</content_attribute>
+ <content_attribute id="violence-fantasy">intense</content_attribute>
+ <content_attribute id="violence-realistic">intense</content_attribute>
+ <content_attribute id="violence-bloodshed">intense</content_attribute>
+ <content_attribute id="violence-sexual">intense</content_attribute>
+ <content_attribute id="violence-desecration">intense</content_attribute>
+ <content_attribute id="violence-slavery">intense</content_attribute>
+ <content_attribute id="drugs-alcohol">moderate</content_attribute>
+ <content_attribute id="drugs-narcotics">moderate</content_attribute>
+ <content_attribute id="drugs-tobacco">moderate</content_attribute>
+ <content_attribute id="sex-nudity">intense</content_attribute>
+ <content_attribute id="sex-themes">intense</content_attribute>
+ <content_attribute id="language-profanity">intense</content_attribute>
+ <content_attribute id="language-humor">intense</content_attribute>
+ <content_attribute id="language-discrimination">intense</content_attribute>
+ <content_attribute id="money-purchasing">mild</content_attribute>
+ <content_attribute id="money-advertising">intense</content_attribute>
+ </content_rating>
</component>
diff --git a/po/de.po b/po/de.po
index 0b01df8..d9e6c31 100644
--- a/po/de.po
+++ b/po/de.po
@@ -7,7 +7,7 @@ msgid ""
msgstr ""
"Project-Id-Version: Melon 0.1.2\n"
"Report-Msgid-Bugs-To: \n"
-"POT-Creation-Date: 2024-03-16 18:50+0100\n"
+"POT-Creation-Date: 2024-03-17 07:54+0100\n"
"PO-Revision-Date: 2024-03-01 11:23+0000\n"
"Last-Translator: Anonymous <noreply@weblate.org>\n"
"Language-Team: German <https://translate.codeberg.org/projects/melon/melon-"
@@ -33,7 +33,11 @@ msgstr ""
msgid "viewer;videos;stream;browse;"
msgstr ""
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:31
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:7
+msgid "Stream videos on the go from different services"
+msgstr ""
+
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:29
#, fuzzy
msgid ""
"Melon allows you to watch videos, subscribe to channels and bookmark "
@@ -42,29 +46,32 @@ msgstr ""
"Melon erlaubt es dir von unterschiedlichen Diensten Videos zu gucken, "
"Kanälen zu folgen und Wiedergabelisten zu merken."
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:34
-msgid "The following services are currently supported:"
-msgstr "Die folgenden Dienste werden zurzeit unterstützt:"
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:32
+msgid ""
+"Access to these services is provided via so called servers (aka plugins), "
+"which communicate with the API of said service. The following services are "
+"currently supported:"
+msgstr ""
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:38
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:37
msgid "Invidious (to access YouTube)"
msgstr "Invidious (bietet Zugang zu YouTube)"
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:39
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:38
msgid "PeerTube (experimental)"
msgstr "PeerTube (experimentell)"
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:40
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:39
msgid "Nebula (account required to watch videos)"
msgstr "Nebula (ein Konto wird benötigt, um Videos zu gucken)"
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:52
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:58
msgid ""
"Default Melon home screen showing: crickets chirping; Subscribe to a channel "
"first, to view uploads"
msgstr ""
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:58
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:64
msgid ""
"List of available servers: Invidious, Nebula, Peertube; including server "
"description"
@@ -72,10 +79,10 @@ msgstr ""
"Liste von verfügbaren Diensten: Invidious, Nebula, Peertube; inklusive "
"Beschreibung"
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:64
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:70
msgid ""
-"Video Screen, with a video player at the top, the video title below, an "
-"expandable description, channel information and a bookmark button"
+"Video Screen, with a video player at the top, video meta data and a bookmark "
+"button"
msgstr ""
#: ../melon/browse/__init__.py:18 ../melon/browse/search.py:58
@@ -836,6 +843,9 @@ msgstr "Eintrag von der Liste entfernen"
msgid "Stream videos on the go"
msgstr "Videos unterwegs streamen"
+#~ msgid "The following services are currently supported:"
+#~ msgstr "Die folgenden Dienste werden zurzeit unterstützt:"
+
#~ msgid "Video quality"
#~ msgstr "Auflösung"
diff --git a/po/fa.po b/po/fa.po
index 34fbc24..54e7f28 100644
--- a/po/fa.po
+++ b/po/fa.po
@@ -7,7 +7,7 @@ msgid ""
msgstr ""
"Project-Id-Version: Melon 0.1.2\n"
"Report-Msgid-Bugs-To: \n"
-"POT-Creation-Date: 2024-03-16 18:50+0100\n"
+"POT-Creation-Date: 2024-03-17 07:54+0100\n"
"PO-Revision-Date: 2024-03-05 05:13+0000\n"
"Last-Translator: sohrabbehdani <behdanisohrab@gmail.com>\n"
"Language-Team: Persian <https://translate.codeberg.org/projects/melon/melon-"
@@ -33,44 +33,51 @@ msgstr ""
msgid "viewer;videos;stream;browse;"
msgstr ""
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:31
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:7
+msgid "Stream videos on the go from different services"
+msgstr ""
+
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:29
msgid ""
"Melon allows you to watch videos, subscribe to channels and bookmark "
"playlists from multiple services."
msgstr ""
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:34
-msgid "The following services are currently supported:"
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:32
+msgid ""
+"Access to these services is provided via so called servers (aka plugins), "
+"which communicate with the API of said service. The following services are "
+"currently supported:"
msgstr ""
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:38
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:37
msgid "Invidious (to access YouTube)"
msgstr ""
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:39
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:38
msgid "PeerTube (experimental)"
msgstr ""
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:40
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:39
msgid "Nebula (account required to watch videos)"
msgstr ""
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:52
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:58
msgid ""
"Default Melon home screen showing: crickets chirping; Subscribe to a channel "
"first, to view uploads"
msgstr ""
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:58
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:64
msgid ""
"List of available servers: Invidious, Nebula, Peertube; including server "
"description"
msgstr ""
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:64
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:70
msgid ""
-"Video Screen, with a video player at the top, the video title below, an "
-"expandable description, channel information and a bookmark button"
+"Video Screen, with a video player at the top, video meta data and a bookmark "
+"button"
msgstr ""
#: ../melon/browse/__init__.py:18 ../melon/browse/search.py:58
diff --git a/po/melon.pot b/po/melon.pot
index e855879..91a9bb5 100644
--- a/po/melon.pot
+++ b/po/melon.pot
@@ -8,7 +8,7 @@ msgid ""
msgstr ""
"Project-Id-Version: Melon 0.2.0\n"
"Report-Msgid-Bugs-To: \n"
-"POT-Creation-Date: 2024-03-16 18:50+0100\n"
+"POT-Creation-Date: 2024-03-17 07:54+0100\n"
"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
"Language-Team: LANGUAGE <LL@li.org>\n"
@@ -32,44 +32,51 @@ msgstr ""
msgid "viewer;videos;stream;browse;"
msgstr ""
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:31
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:7
+msgid "Stream videos on the go from different services"
+msgstr ""
+
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:29
msgid ""
"Melon allows you to watch videos, subscribe to channels and bookmark "
"playlists from multiple services."
msgstr ""
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:34
-msgid "The following services are currently supported:"
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:32
+msgid ""
+"Access to these services is provided via so called servers (aka plugins), "
+"which communicate with the API of said service. The following services are "
+"currently supported:"
msgstr ""
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:38
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:37
msgid "Invidious (to access YouTube)"
msgstr ""
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:39
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:38
msgid "PeerTube (experimental)"
msgstr ""
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:40
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:39
msgid "Nebula (account required to watch videos)"
msgstr ""
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:52
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:58
msgid ""
"Default Melon home screen showing: crickets chirping; Subscribe to a channel "
"first, to view uploads"
msgstr ""
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:58
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:64
msgid ""
"List of available servers: Invidious, Nebula, Peertube; including server "
"description"
msgstr ""
-#: ../data/icu.ccw.Melon.metainfo.xml.in.in:64
+#: ../data/icu.ccw.Melon.metainfo.xml.in.in:70
msgid ""
-"Video Screen, with a video player at the top, the video title below, an "
-"expandable description, channel information and a bookmark button"
+"Video Screen, with a video player at the top, video meta data and a bookmark "
+"button"
msgstr ""
#: ../melon/browse/__init__.py:18 ../melon/browse/search.py:58
--
2.44.0

55
srcpkgs/melon/APKBUILD Executable file
View file

@ -0,0 +1,55 @@
# Contributor: Jakob Meier <comcloudway@ccw.icu>
# Maintainer: Jakob Meier <comcloudway@ccw.icu>
pkgname=melon
pkgver=0.2.0
pkgrel=0
pkgdesc="Melon is a video player that aims to be mobile friendly. Stream videos on the go from multiple sources."
url="https://codeberg.org/comcloudway/melon"
arch="noarch"
license="GPL-3.0-or-later"
depends="
gettext
gst-plugins-rs
gtk4.0
libadwaita
py3-beautifulsoup4
py3-gobject3
py3-lxml
py3-requests
py3-unidecode
"
makedepends="
desktop-file-utils
gtk4.0-dev
libadwaita-dev
meson
"
subpackages="$pkgname-lang $pkgname-pyc"
source="
melon-$pkgver.tar.gz::https://codeberg.org/comcloudway/melon/archive/$pkgver.tar.gz
0001-update-metainfo-file-to-pass-appstream-validate.patch
"
builddir="$srcdir/$pkgname"
prepare() {
default_prepare
ls -lah
}
build() {
abuild-meson build
ninja -C build
}
check() {
meson test -C build --print-errorlog
}
package() {
DESTDIR="$pkgdir" meson install -C build
}
sha512sums="
beb470c0c59011c47a94427ee4a3dc661a2b713714d1835c1c3e190c15aa9df607facadbdd635381c2331d31f2731b9314e210ea1a45134d84114b8c03540c40 melon-0.2.0.tar.gz
6ec18aa024605be6426f2bad8b585e86ee2e64212aa09244fc68f7b889deeaacd63bcb067e2226ffa9a40eda4795ecf9aa3adb212b53e4ec708cb9d757fffb79 0001-update-metainfo-file-to-pass-appstream-validate.patch
"